Follow

What type of device do I need to run Waterlogue?

You will need an Apple iPhone, iPad or iPod touch that is running iOS version 7 or greater or a device that runs Windows 10 with at least 1 gigabyte of RAM.

The current version of Waterlogue will not run on:

  • Android phones or tablets
  • Kindle Fire
  • MacBooks or iMacs

Comments